We have discontinued this forum and moved support tickets to the GitHub issue tracker. More info

Moderator: Steven

 
calibrae
Topic Author
Posts: 1
Joined: 19 Jul 2016, 15:05

Manually setting fan speed makes kernel_task eats all my CPU

19 Jul 2016, 15:09

It's summer, so I'd like to lower my fan speed very much
I'm on El Capitain on a 2015 rMBP 15.

As soon as I manually set the fan speed, the kernel_task process starts running very hot.
Anything I can do?

Thanks !
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Manually setting fan speed makes kernel_task eats all my CPU

20 Jul 2016, 11:56

calibrae
Can you please give us a screenshot or even record a video ?
 
mad_1979
Posts: 3
Joined: 26 Oct 2016, 13:55

Manually setting fan speed makes kernel_task eats all my CPU

26 Oct 2016, 14:13

Hello,

I have exactly the same issue. I installed MFC yesterday, because the fans at my MBP 15" 2015, Radeon R9 M370X, were quite annoying, especially when looking to flash- and html5 videos on the web.

Today I recognized a sudden slowdown of the system (OSX 10.11.6) and a kernel_task CPU activity of about 500% in average and 780% peak. I had to deselect MFC autostart option, quit MFC, shut down the computer for 5 min with power cable detached and reboot - then it workd again correctly.
Attachments
image1.JPG
Screenshot Activity monitor
image1.JPG (109.73 KiB) Viewed 7496 times
 
mad_1979
Posts: 3
Joined: 26 Oct 2016, 13:55

Manually setting fan speed makes kernel_task eats all my CPU

26 Oct 2016, 14:13

Would be nice, if anyone could help.

Thanks,

Mat
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Manually setting fan speed makes kernel_task eats all my CPU

26 Oct 2016, 14:24

There's no evidence that this problem is because of Macs Fan Control. After the reboot kernel_task CPU usage is always 0
 
mad_1979
Posts: 3
Joined: 26 Oct 2016, 13:55

Manually setting fan speed makes kernel_task eats all my CPU

11 Nov 2016, 12:07

Hello,

It definitely has to do something with macsfancontrol. I worked 2 weeks without starting the program: CPU usage is fine. I started it again, 1 minute after: same Problem 400% CPU usage and Macbook reacting very slow.

Best,

Matthias
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Manually setting fan speed makes kernel_task eats all my CPU

22 Dec 2016, 19:58

Which fan control settings in MFC do you use? (a screenshot or technical info from the preferences dialog).
 
banjopotato
Posts: 3
Joined: 08 Jan 2017, 11:46

Re: Manually setting fan speed makes kernel_task eats all my CPU

08 Jan 2017, 12:01

I have this problem consistently. Setting MFC to Custom Control (measuring temp on CPU Diode, fan increasing from 65C to a max of 99C with min fan at 2000 and max fan at 6200) consistently results in kernel_task starting to take upwards of 200% of CPU and slowing down the machine to the point that it become unusable. Setting MFC back to automatic gets kernel_task back to something more reasonable.

The thing is: it takes a while for the kernel_task problem to appear. But it does so consistently.

Screenshot:

SafariScreenSnapz134.jpg
SafariScreenSnapz134.jpg (79.88 KiB) Viewed 7082 times


Technical info:

Macs Fan Control 1.4.5
MacBookPro8,1
CPU: Intel(R) Core(TM) i5-2435M CPU @ 2.40GHz [100]
GPU: Intel HD Graphics 3000
macOS 10.10.5

Fans:
Exhaust-min{2000}curr{4006}max{6200}mode{2,TC0D,65,99}


TempSensors:
TB0T (Battery Max) - 37.6992, 37.6992
TB1T (Battery Sensor 1) - 31, 31
TB2T (Battery Sensor 2) - 30.3984, 30.3984
TC0C () - 81.7969, 81.7969
TC0D (CPU Diode) - 81.625, 81.625
TC0E () - 83.5117, 83.5117
TC0F () - 84.207, 84.207
TC0J () - 0.695312, 0.695312
TC0P (CPU Proximity) - 75.75, 75.75
TC1C (CPU Core 1) - 80, 80
TC2C (CPU Core 2) - 81, 81
TCGC (GPU PECI) - 81, 81
TCSA () - 80, 80
TCTD () - -1, 255.871
TM0P (Memory Proximity) - 53.875, 53.875
TM0S (Memory Slot) - 64.8438, 64.8438
TMBS () - -1, 0
TP0P () - 59.375, 59.375
TPCD (Platform Controller Hub Die) - 70, 70
TW0P () - -1, 129
Th1H (Heatsink Proximity) - 56.5, 56.5
Ts0P (Palm Rest) - 39.625, 39.625
Ts0S () - 51.6172, 51.6172


Disk drives:
HGST HTS721010A9E630 - 46
Samsung SSD 840 EVO 500GB - 46
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Manually setting fan speed makes kernel_task eats all my CPU

08 Jan 2017, 13:18

How long does it take to wait until kernel_task eats out the CPU ?
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Manually setting fan speed makes kernel_task eats all my CPU

10 Jan 2017, 19:42

 
banjopotato
Posts: 3
Joined: 08 Jan 2017, 11:46

Re: Manually setting fan speed makes kernel_task eats all my CPU

09 Mar 2017, 15:43

I've found that even when I remove the relevant file to prevent kernel_task from taking up all my CPU, eventually many other apps start increasing the CPU load and, especially, the load average. I start to see 1 minute load averages of 15, 20 and higher despite the fact that the computer isn't doing much.

Returning Macs Fan Control's settings to Automatic stops the problem. But then I have loud fan noise. :(

This is true now on Sierra 10.12.3 with MFC 1.4.7 on Macbook Pro 8,1.
 
norisounds
Posts: 1
Joined: 12 Mar 2017, 16:56

Re: Manually setting fan speed makes kernel_task eats all my CPU

12 Mar 2017, 17:51

Hi there,

I also have the same issue that after about 5 mins, kernal_task will pin my CPU and the only way to stop it is to put the macsfancontrol back to automatic and do a reboot.

I have this problem on 2 macs. Late 2013 mbp 15" and a mid 2015 mbp 15" both running El Cap.

This can be easily reproduced by plugging in 2 external monitors (1 via thunderbolt, other via hdmi). With this setup, my workload/temp is low (55-60C) but the fans kick in to between 4200-4400rpm. When I set Macsfancontrol to manual from CPU with a range of 65-95C (fans about 3000rpm at these temps), kernal_task will bring my machine to its knees in less than 5 mins. 

I think the problem is brought on when using Macsfancontrol to lower the fan speed at higher temps/loads to get a quieter mac rather than increasing fan speed at higher temps to get a cooler machine. 

I'm not sure how Macsfancontrol works but is it possible to 'trick' the OS into thinking its getting the fan rpm it is expecting? For example the fan gets the command to run at 3000rpm while the OS gets a signal from Macsfancontrol that the fan is running at 4400rpm. Maybe this way, the OS will stop kernel_task from going crazy.

Anyhow, I hope you guys can reproduce this. Let me know if there is anything I can test/do to help track the issue down.
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Manually setting fan speed makes kernel_task eats all my CPU

14 Mar 2017, 12:17

Hi,

I think that kernel_task begins to eat all the CPU when the mac is overheated. So it likely means that you set the RPM speed which not enough to cool down the mac.
But (for example) if you set rpm speed to max in the same situation, it won't happen
 
banjopotato
Posts: 3
Joined: 08 Jan 2017, 11:46

Re: Manually setting fan speed makes kernel_task eats all my CPU

22 Mar 2017, 11:50

Steven wrote:
Hi,

I think that kernel_task begins to eat all the CPU when the mac is overheated. So it likely means that you set the RPM speed which not enough to cool down the mac.
But (for example) if you set rpm speed to max in the same situation, it won't happen


I'm not sure I understand this response. I've disabled kernel_task but other apps--always Apple apps or parts of the OS--start doing the same thing: taking up increasing amounts of CPU. So the Finder (or Safari or WindowServer) will start using up CPU and slowing down the machine.

My settings are for fan to start at 64 degrees C (read on the CPU diode) with a Maximum Temperature of 99c.

Perhaps what you're saying is that "Maximum Temperature" really means "temperature at which you'd like the fan to run at maximum speed" and that it should therefore be set at something like 85c.

If so, perhaps it should be relabeled. Anyway, I'll set MFC now to a "maximum temperature" of 85c and report back.
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Manually setting fan speed makes kernel_task eats all my CPU

27 Mar 2017, 19:23

This issue shows up when a mac is trying to prevent overheating. Basically kernel_task takes up most of the CPU in order to allow less performance for heavy apps.

Who is online

Users browsing this forum: Bing [Bot] and 2 guests