We have discontinued this forum and moved support tickets to the GitHub issue tracker. More info

Moderator: Steven

 
hiram
Topic Author
Posts: 1
Joined: 27 Oct 2017, 01:13

MFC is not working properly on High Sierra (iMac Mid 2011)

27 Oct 2017, 01:15

MFC not working properly on High Sierra (iMac Mid 2011). Even if I setup thresholds for temperature or RPM, the MFC doesn't obey what was setup.

Is it incompatible with IMac 2011?

Thanks,
Hiram
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: MFC is not working properly on High Sierra (iMac Mid 2011)

09 Nov 2017, 17:37

 
mrmachine
Posts: 2
Joined: 21 Nov 2017, 23:49

Re: MFC is not working properly on High Sierra (iMac Mid 2011)

21 Nov 2017, 23:59

Same thing here on a 2011 iMac.

Computer is overheating and nothing I do in MFC seems to make a difference. I have added an SSD and upgraded the HDD and previously I used MFC to prevent macOS from spinning the HDD fan at 100% all the time.

Now with High Sierra, MFC tells me the HDD fan is spinning at 1979 rpm all the time (+/- 2).

I tried changing that fan to auto control, or custom (constant value 5500), or custom (constant value 1100), or sensor based (WDC WD40EFRX-68WT0N0, from 42c to 52c -- this is what I previously used before High Sierra).

HDD temp is currently 57c and nothing will make this fan spin faster.

Here's a screenshot:

Image

Here's the technical info:

Macs Fan Control 1.4.8.1

iMac12,2
CPU: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz [100]
GPU: Intel HD Graphics 3000 [active], AMD Radeon HD 6970M
macOS 10.13.1

Fans:
ODD-min{1150}curr{1345}max{2926}mode{0}
HDD-min{1100}curr{1978}max{5500}mode{1,5500}
CPU-min{940}curr{3145}max{2901}mode{0}


TempSensors:
TA0P () - 30.0234, 30.0234
TA0V () - 32.1133, 32.1133
TA0p (Ambient) - 34.75, 34.75
TC0H () - 54.875, 54.875
TC0P () - 55.5, 55.5
TC0c (CPU Core 1) - 63, 63
TC0h (CPU Heatsink) - 54.875, 54.875
TC0p (CPU Proximity) - 55.5, 55.5
TC1c (CPU Core 2) - 65, 65
TC2c (CPU Core 3) - 65, 65
TC3c (CPU Core 4) - 61, 61
TCGc (GPU PECI) - 65, 65
TCSc () - 62, 62
TCXc (CPU PECI) - 66.5625, 66.5625
TG0D () - 74.5, 74.5
TG0H () - 68.25, 68.25
TG0d (GPU Diode) - 74.5, 74.5
TG0h (GPU Heatsink) - 68.25, 68.25
TG0p (GPU Proximity) - 68, 68
TH0O () - 9, 9
TH1O () - 5.61328, 5.61328
TL0P () - 46.5195, 46.5195
TL0V () - 52.8359, 52.8359
TL0p (LCD proximity) - 58.6875, 58.6875
TL1P () - 58.3125, 58.3125
TL1V () - 49.0664, 49.0664
TL1p () - 58.3125, 58.3125
TL1v () - 49.0586, 49.0586
TL2V () - 55.9375, 55.9375
TLAV () - 55.9375, 55.9375
TLBV () - 51.3477, 51.3477
TLCV () - 52.8359, 52.8359
TO0P () - 53.25, 53.25
TO0p (Optical Drive) - 54.25, 54.25
TPCD (Platform Controller Hub Die) - 65, 65
TS0P () - 49.25, 49.25
TS0V () - 46.2773, 46.2773
TS0p () - 49.25, 49.25
TS2P () - 51.25, 51.25
TS2V () - 48.4844, 48.4844
TS2p () - 51.25, 51.25
Tm0P () - 55.375, 55.375
Tm0p () - 55.375, 55.375
Tp1P () - 57.875, 57.875
Tp1p () - 57.875, 57.875
Tp2H () - 63.375, 63.375
Tp2h () - 63.375, 63.375
Tp3H () - 57.625, 57.625
Tp3h (PSU Primary) - 57.625, 57.625


Disk drives:
WDC WD40EFRX-68WT0N0 - 57
Samsung SSD 840 EVO 1TB - 55
ST2000LM003 HN-M201RAD - 51
ST2000LM003 HN-M201RAD - 52
ST2000LM003 HN-M201RAD - 47
ST2000LM007-1R8174 - 50
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: MFC is not working properly on High Sierra (iMac Mid 2011)

22 Nov 2017, 14:13

MFC is not designed to work with hackintosh
 
mrmachine
Posts: 2
Joined: 21 Nov 2017, 23:49

Re: MFC is not working properly on High Sierra (iMac Mid 2011)

23 Nov 2017, 12:06

Is that seriously your only response?

This is not a "hackintosh". It's a 2011 iMac with the original HDD replaced. Not surprising for a 6 year old machine. And MFC was working fine on this machine before.

The app is apparently still able to read the temperature sensor still, but is no longer able to control the fan speed. The fans are still stock.
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: MFC is not working properly on High Sierra (iMac Mid 2011)

23 Nov 2017, 14:34

I'm sorry I was wrong.

Setting max speed for any fan doesn't work? Do you have any other fan controlling app installed? Did you try to reset SMC?
https://support.apple.com/en-us/HT201295

Who is online

Users browsing this forum: No registered users and 1 guest