We have discontinued this forum and moved support tickets to the GitHub issue tracker. More info

Moderator: Steven

 
oscgonzales
Topic Author
Posts: 1
Joined: 04 Jun 2013, 19:19

Slow fan speed changes with temperature changes

04 Jun 2013, 19:26

On my 2006 iMac the program version 1.0.1 is very slow responding to temperature changes. When I run something that uses about 80% of the CPU the temperatures naturally go up but even when the temperature is above the sensor set-point (using the GPU sensor to change CPU fan), the fan doesn't speed up for a couple of minutes. Then when the temperature is down is doesn't slow down right away. Too much hysteresis! Is this a bug or is it intended?
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Slow fan speed changes with temperature changes

05 Jun 2013, 07:53

Well, it can be true if temperature changes too fast this issue can take place :(

using the GPU sensor to change CPU fan

This is absolutely not correct
 
Jon_K
Posts: 9
Joined: 27 Aug 2013, 21:39

Re: Slow fan speed changes with temperature changes

27 Aug 2013, 21:43

Is this behavior due to Macs Fan Control, or due to the Mac hardware or OS?
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Slow fan speed changes with temperature changes

27 Aug 2013, 21:45

Jon_K, do you have the same problem? Fan speed is too high after temp sensor value dropped?

Please share your experience with some technical information (screenshots, example values).
 
Jon_K
Posts: 9
Joined: 27 Aug 2013, 21:39

Re: Slow fan speed changes with temperature changes

27 Aug 2013, 23:57

I'm using a Mac Pro mid 2010 5,1. I have Boost A, Boost B & Intake all set at heatsink 50C/75C. Ambient is 37C. CPU A is about 54C at idle. In this state Boost A is at 800, B at 800, Intake at 600 & Exhaust at 950. When I put full load on the processors, the temps quickly rise. The fans don't spin up until CPU A is about 87C - 1 min 50 sec after full load was applied. Once the fans spin up, CPU A drops to 72-73C. After about 4 minutes, the fans spin down. CPU A then rises to 82-83C and holds. In this state Boost A is at 1700, B at 1500, Intake at 1150 & Exhaust at 1430.
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Slow fan speed changes with temperature changes

28 Aug 2013, 09:00

Ok, this is clear, thanks. The sensor-based algorithms will be improved in the next version
 
Jon_K
Posts: 9
Joined: 27 Aug 2013, 21:39

Re: Slow fan speed changes with temperature changes

08 Sep 2013, 01:36

Behavior did not change with 1.1.1
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Slow fan speed changes with temperature changes

12 Sep 2013, 08:10

Yes, but it will be fixed in next updates
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Slow fan speed changes with temperature changes

01 Oct 2013, 20:10

Improved in 1.1.5
 
Jon_K
Posts: 9
Joined: 27 Aug 2013, 21:39

Re: Slow fan speed changes with temperature changes

06 Oct 2013, 01:05

1.1.5 is much better. Now the fans don't play catch-up, sounding like jet engines. The temps rise, and the fans spin up with them. Temps never get as high as before.
Thanks!
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Slow fan speed changes with temperature changes

06 Oct 2013, 07:59

Great! :smile:

Who is online

Users browsing this forum: No registered users and 2 guests