We have discontinued this forum and moved support tickets to the GitHub issue tracker. More info

Moderator: Steven

 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Install and Trace: Error 193

27 Jan 2015, 23:35

Skrell
Thank you, looking forward to.
 
roger_m
Posts: 11
Joined: 21 May 2015, 05:38

Re: Install and Trace: Error 193

21 May 2015, 05:45

I'm experiencing the exact same problem. It apperars to be due to Install Tool not being able to handle spaces in the path to installer that is to be monitored.

As an example, I tried monitoring an installer in my C:\Users\User Name\Downloads folder and it failed. However, it worked when I copied the installer to C:\ and tried monitoring it from there. My Windows account name is made of two words, with a space seperating them. I would seem that Uninstall Tool is not able to handle the space being there. This is a problem for Windows too in some instances. For example, if open the Windows Run dialogue box, and enter C:\Users\User Name Windows is unable to open the folder. However if I enclose it in quotes, i.e. "C:\Users\User Name" the folder opens in Explorer.
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Install and Trace: Error 193

21 May 2015, 07:56

Hi and thank you for the report!

But I don't think it's because of spaces.

1. Can you make a test and try the same uninstaller from
"C:\Folder"
and
"C:\Folder with space"

2. I think this error comes on some machines only from a certain folder.
What is the exact folder with the 193 error?

Thanks again.
 
roger_m
Posts: 11
Joined: 21 May 2015, 05:38

Re: Install and Trace: Error 193

21 May 2015, 08:35

Thanks for the quick reply. The monitoring is working from the folder with a space created in C:\.

The folder causing the problems is C:\Users\My Account\Downloads
 
roger_m
Posts: 11
Joined: 21 May 2015, 05:38

Re: Install and Trace: Error 193

21 May 2015, 08:47

It help to know that I was able to access the folder I created from the Run dialogue box by just entering the folder name C:\My Folder, but to open my user folder I needed quotes "C:\Users\User Folder".
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Install and Trace: Error 193

21 May 2015, 08:52

roger_m
Just created a user called "User Name", logged in and successfully started Install Tracker from
C:\Users\User Name\Downloads\anytoiso_setup.exe

- Does your user name contain international characters?
- Are you using the latest version of UT (3.4.2)?
 
roger_m
Posts: 11
Joined: 21 May 2015, 05:38

Re: Install and Trace: Error 193

21 May 2015, 08:56

I'm only using letters, no international characters. I'm using the latest version.

Also, I'm using Windows 10 if that helps.
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Install and Trace: Error 193

21 May 2015, 09:19

Does it happen when starting setup file from context menu only OR also when starting from the main UT window (Install and Trace button on the bottom toolbar)
 
roger_m
Posts: 11
Joined: 21 May 2015, 05:38

Re: Install and Trace: Error 193

21 May 2015, 09:25

I get the same error either way.
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Install and Trace: Error 193

21 May 2015, 09:30

roger_m
Unfortunately this error 193 has never reproduced for years on our machines. We can prepaire a special (debug) version of the app to locate the problem.
Will you be able to test it?

PS. I'm 99% SURE It's actually a Windows bug related with CreateProcess function
 
roger_m
Posts: 11
Joined: 21 May 2015, 05:38

Re: Install and Trace: Error 193

21 May 2015, 09:44

Yes, most definitely,m that would be great.
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Install and Trace: Error 193

21 May 2015, 10:14

roger_m
In progress, it will take a couple of hours
 
Skrell
Posts: 33
Joined: 16 Sep 2014, 19:28

Re: Install and Trace: Error 193

21 May 2015, 12:31

I'd be willing to try the debug version too ! :)
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Install and Trace: Error 193

21 May 2015, 21:41

roger_m
I have an idea. Do you have anti-virus installed (which one?)? If yes, please remove it, reboot and try again to start an .exe from the Downloads folder.
I know it's painful, you may try to disable its real-time protection first.

Skrell
Do you experience the same error?
 
roger_m
Posts: 11
Joined: 21 May 2015, 05:38

Re: Install and Trace: Error 193

21 May 2015, 22:30

No, I don't use antivirus software at the moment.
 
Skrell
Posts: 33
Joined: 16 Sep 2014, 19:28

Re: Install and Trace: Error 193

21 May 2015, 22:57

Yes... Look back a page :-P
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Install and Trace: Error 193

21 May 2015, 23:42

roger_m
Skrell
Please use this test build. It will only produce a single DEBUG entry to the installation log (you can save it).

PS. The only thing that would help me to reproduce the issue is to have exactly the same Windows as you do.
And the only way to achieve it is to create a copy of your Windows drive using Disk2vhd utility. The disk image will contain your personal data, so please clean it by mounting the resulting .vhd file and removing all your data. Also I'd need a story how to reproduce the issue on this machine.
Yes it really sounds crazy :(
Attachments
sshot-2015-05-22-[02-32-28].png
sshot-2015-05-22-[02-32-28].png (39.84 KiB) Viewed 14006 times
 
Skrell
Posts: 33
Joined: 16 Sep 2014, 19:28

Re: Install and Trace: Error 193

21 May 2015, 23:53

I'm not sure how this helps you but here is my log:

19:51:47 Starting Install Tracker service...
19:51:48 Service version is: 0x103
19:51:48 Starting KillerCleaner_32bit.exe...
19:51:48 DEBUG: C:\Documents and Settings\Administrator\Desktop\KillerCleaner_32bit.exe
19:51:48 Error: Cannot start the setup process (error 193)
19:51:48 Analyzing installation, please wait...
19:51:48 0 installation entries detected
 
roger_m
Posts: 11
Joined: 21 May 2015, 05:38

Re: Install and Trace: Error 193

22 May 2015, 04:02

That is what is happening for me too.
 
User avatar
Steven
CrystalIDEA Developer
Posts: 2294
Joined: 21 Dec 2009, 11:48
Location: CrystalIDEA headquarters
Contact:

Re: Install and Trace: Error 193

22 May 2015, 08:23

Skrell
roger_m
I'm sorry but I need a copy of the Windows drive to fix the problem (if it can be fixed) :(
(see my post above)

Who is online

Users browsing this forum: No registered users and 2 guests